Friday, May 07, 2010

:: ATI vs Slackware-current ::

Aqueles que como eu têm uma placa de vídeo da ATI, já notaram como tem sido um saco instalar os últimos drivers no Slackware-current (seja 32 ou 64 bits), certo?

Bom, fuça aqui e fuça ali eu consegui um SlackBuild e um driver que dão uma resolvida na questão:

fglrx-8.723.1 (é um link pro rapidshare)

Empacotei toda a tralha que eu tenho lá em casa e mandei pro RapidShare, pra facilitar a vida de outras criaturas atormentadas pela ATI ahahaha

Ah, quem estiver usando slackware-current 32bits, favor editar o arquivo fglrx.SlackBuild e mudar o ARCH. Fora isso é só rodar o script, esperar o package ser criado, instalar (com installpkg ou "upgradepkg --install-new"), reiniciar o PC e correr pra galera.

Bom, fiz minha boa ação de hoje ;)

4 comments:

Rodrigo said...

Kenjiro fiz o que vocẽ mandou e esta dando o seguinte erro:


patching file lib/modules/fglrx/build_mod/drmP.h
patching file lib/modules/fglrx/build_mod/firegl_public.c
Hunk #3 succeeded at 1470 (offset -2 lines).
patching file lib/modules/fglrx/build_mod/kcl_acpi.c
Hunk #1 succeeded at 15 with fuzz 2.
patching file lib/modules/fglrx/build_mod/kcl_agp.c
patching file lib/modules/fglrx/build_mod/kcl_io.c
patching file lib/modules/fglrx/build_mod/kcl_osconfig.h
patching file lib/modules/fglrx/build_mod/kcl_pci.c
patching file lib/modules/fglrx/build_mod/kcl_str.c
patching file lib/modules/fglrx/build_mod/kcl_wait.c
patching file lib/modules/fglrx/build_mod/make.sh
cp: cannot stat `/arch//lib/modules/fglrx/build_mod/libfglrx_ip.a.GCC4': No such file or directory
root@slack:/home/rodrigo/Downloads/fglrx#

O que faço para resolver?

Desde ja agradeço a ajuda.....

Kenjiro said...

Rodrigo, qual versão do Slack tu tá usando? 32 ou 64bits? Qual versão do Kernel?

Eu não tive problemas desse tipo.

Rodrigo said...

Slackware 13.1 32bits
2.6.33.4-smp

Kenjiro said...

Meio estranho...

Chegaste a pesquisar no google?

Pelo que eu vi no erro ele não está achando o "/arch//lib/modules/fglrx/build_mod/libfglrx_ip.a.GCC4"

Eu realmente não tentei instalar o driver em um slack 32bits, pq só tenho VGA da ATI no meu desktop, que é 64bits.

Tenta pesquisar no google primeiro, se não pintar uma solução, apela pra lista do gus-br ;)